Copyright

© Copyright 2001 SAP AG. All rights reserved.

No part of this publication may be reproduced or transmitted in any form or for any purpose
without the express permission of SAP AG. The information contained herein may be changed
without prior notice.

Some software products marketed by SAP AG and its distributors contain proprietary software
components of other software vendors.

Microsoft®, WINDOWS®, NT®, EXCEL®, Word®, PowerPoint® and SQL Server® are registered
trademarks of Microsoft Corporation.

IBM®, DB2®, OS/2®, DB2/6000®, Parallel Sysplex®, MVS/ESA®, RS/6000®, AIX®, S/390®,
AS/400®, OS/390®, and OS/400® are registered trademarks of IBM Corporation.

ORACLE® is a registered trademark of ORACLE Corporation.

INFORMIX®-OnLine for SAP and Informix® Dynamic Server™ are registered trademarks of
Informix Software Incorporated.

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.

HTML, DHTML, XML, XHTML are trademarks or registered trademarks of W3C®, World Wide
Web Consortium,
Massachusetts Institute of Technology.

JAVA® is a registered trademark of Sun Microsystems, Inc.

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for
technology invented and implemented by Netscape.

SAP, SAP Logo, R/2, RIVA, R/3, ABAP, SAP ArchiveLink, SAP Business Workflow, WebFlow,
SAP EarlyWatch, BAPI, SAPHIRE, Management Cockpit, mySAP.com Logo and mySAP.com
are trademarks or registered trademarks of SAP AG in Germany and in several other countries
all over the world. All other products mentioned are trademarks or registered trademarks of their
respective companies.
# Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>Caution</td>
</tr>
<tr>
<td></td>
<td>Example</td>
</tr>
<tr>
<td></td>
<td>Note</td>
</tr>
<tr>
<td></td>
<td>Recommendation</td>
</tr>
<tr>
<td></td>
<td>Syntax</td>
</tr>
</tbody>
</table>
Contents

PP - Work Centers .................................................................................................................... 7
  Work Center .......................................................................................................................... 8
  Authorization ......................................................................................................................... 11
  Display Administrative Data ............................................................................................... 12
  Creating, Changing and Displaying Work Centers ............................................................. 13
  Creating and Changing Work Centers by Copying ............................................................ 14
  Checking Work Centers ....................................................................................................... 15
  Renaming Work Centers ....................................................................................................... 16
  Locking and Unlocking Work Centers .................................................................................. 17
  Deleting Work Centers, Setting Deletion Flags ................................................................. 18
  Classifying Work Centers ..................................................................................................... 19
    Creating Classes .................................................................................................................. 20
  Assigning Work Centers to Subsystems ............................................................................. 21
  Archiving Work Centers ....................................................................................................... 22

Basic Data ................................................................................................................................ 23

Performance Efficiency Rate Key ........................................................................................... 24
  Standard value ....................................................................................................................... 25
  Creating a Short Text Description of the Work Center in Different Languages .................. 26

Default values ......................................................................................................................... 27

Reference Indicator .................................................................................................................. 28

Control Keys ............................................................................................................................. 29

Standard Text Keys .................................................................................................................. 30

Editing Standard Text ............................................................................................................. 31

Capacities ................................................................................................................................... 32

Capacity Categories .................................................................................................................. 34

Available Capacities .................................................................................................................. 35
  Standard Available Capacity ................................................................................................. 37
  Available Capacity Versions ................................................................................................. 39
  Interval of Available Capacity ............................................................................................... 41
    Example: Interval of Available Capacity with a Cycle Duration of 1 Day ......................... 42
    Example: Interval of Available Capacity with a Cycle Duration of 7 Days ...................... 43
  Shifts ....................................................................................................................................... 45
    Example: Interval of Available Capacity with Shifts ....................................................... 46
  Shift Definition and Shift Sequence ....................................................................................... 48

Maintenance of Available Capacities ....................................................................................... 50
  Maintenance of Standard Available Capacities ................................................................... 51
  Maintenance of Available Capacity Versions ...................................................................... 52
    General Functions .............................................................................................................. 53
  Maintaining Intervals of Available Capacity ....................................................................... 54
  Displaying Intervals of Available Capacity ......................................................................... 56
  Maintaining Shifts .................................................................................................................. 57
  Activating Available Capacity Versions .............................................................................. 59
  Displaying Available Capacity .............................................................................................. 60
Maintaining Capacities

- Creating Capacities by Copying from
- Reference Available Capacity
- Copying or Referencing Capacities
- Assigning Pooled Capacities
- Maintaining Individual Capacities
- Resetting a Capacity
- Assigning or Deleting Capacity Categories in Work Centers
- Choosing Units of Measure for Available Capacities
- Distribution Key - Distributing Capacity Requirements
- General Capacity Data
- Setting Up determination of Actual Capacity Requirements
- Example: Assigning Activities to Actual Capacity Requirements

Planning Details for Capacity Planning

Cumulation of Available Capacities and Capacity Requirements

- Static Cumulation
- Period Pattern Key
- Dynamic Cumulation
- Cumulation of Available Capacities

Scheduling Data in Work Centers

Maintaining Scheduling Data

Interoperation Time

Costing

- Example: Costing with Cost Centers
- Assigning a Work Center to a Cost Center

Costing with Business Processes

- Assigning a Work Center to a Business Process

Assignments to Objects in the Human Resource Management System (HR)

Assigning HR Objects to Work Centers

Assigning HR Objects to Capacities

Qualifications and Requirements Profiles

Validity Periods

Technical Data for Calculating Standard Values with CAPP

Assigning Processes

Work center hierarchy

Hierarchy Creation

- Creating Hierarchies
- Assigning Work Centers in Work Center Maintenance
- Assigning Work Centers in Hierarchy Maintenance
- Calling up a Hierarchy Graphic
- Connecting Work Centers
- Deleting Work Center Assignments

Displaying Hierarchy Structure as a List

Explosion Stop

Reporting

Displaying Standard Reports

- Reporting from Hierarchy Work Centers only

Displaying Change Documents
PP - Work Centers
Work Center

Definition
Operations are carried out at a work center. In the R/3 System work centers are business objects that can represent the following real work centers, for example:

- Machines, machine groups
- Production lines
- Assembly work centers
- Employees, groups of employees

Use
Together with bills of material and routings, work centers belong to the most important master data in the R/3 production planning and control system. Work centers are used in task list operations and work orders. Task lists are for example routings, maintenance task lists, inspection plans and standard networks. Work orders are created for production, quality assurance, plant maintenance and for the Project System as networks.

Data in work centers is used for

- Scheduling
  Operating times and formulas are entered in the work center, so that the duration of an operation can be calculated.

- Costing
  Formulas are entered in the work center, so that the costs of an operation can be calculated. A work center is also assigned to a cost center.

- Capacity planning
  The available capacity and formulas for calculating capacity requirements are entered in the work center.

- Simplifying operation maintenance
  Various default values for operations can be entered in the work center.

The following graphic illustrates the use of work center data.
Use of work center data

Structure

A work center is created for a plant and is identified by a key. The work center category [Page 123], which you define in Customizing the work center, determines which data can be maintained in the work center.

The data is grouped thematically together in screens and screen groups. Examples of such screen or screen groups are:

- Basic Data
- Assignments (to cost centers, Human Resource Management System (HR))
- Capacities
- Scheduling
- Default values
- Hierarchy
- Technical data
Work Center

Integration

Task Lists

Work centers are assigned to operations in task lists. If you change default values in a work center, the changes are effective in the task list if a reference indicator [Page 28] has been set for the default value.

Work Center Hierarchies

Work centers can be arranged in hierarchies. These are important in capacity planning. You use hierarchies to cumulate available capacities and capacity requirements in a hierarchy work center.

Assignments to Objects in the Human Resource Management System

A Logistics work center can be assigned to either an organizational unit or a work center in the Human Resource Management System (HRMS). Assignments to other HR-objects, for example employees or qualifications, can be maintained via the HR work center.
Authorization

What a user is allowed to do with work center data depends on the authorizations he has been given in the user master record:

- **Activity authorization** allows the user to create, edit, display and delete work centers.
- **Work center category authorization** allows a user to maintain a particular work center category.
- Plant authorization allows a user to maintain all work centers in a particular plant.

Your system administration is responsible for authorizations. For further information about users and authorizations see the R/3 Library *BC Basis*
Display Administrative Data

Prerequisites
You can display the following administrative data about a work center:

- Object ID that the work center is stored under in the system
- When and by whom the work center was last changed
- Locked indicator or deletion indicator

Procedure
Choose Extras → Administrative data in any of the work center views.
Creating, Changing and Displaying Work Centers

Prerequisites

The work center data [Page 8] is thematically arranged in various screens or screen groups. Which screens and data you can edit are determined by the work center category [Page 123] that you define when you create a work center.

When you create a work center you are lead through various screens, the sequence depends on the work center category. You navigate with Next screen and Previous screen or, if you do not want to enter required data [Page 123], skip.

If you have stopped entering data for a work center, saved and exited, you can see which data is missing by checking the work center [Page 15]. The system then leads you to the screens you still need to edit.

When you are changing or displaying a work center, you can use Skip to navigate from one screen to another.

You can use a reference to create or change a work center. For more information, see Creating and Changing Work Centers by Copying [Page 14]

Procedure

1. Choose Logistics → Production → Master data → Work centers from the main R/3 menu.
   
   The Work centers area menu is displayed.

2. Choose Work center → Create, Change or Display.

3. Enter the plant where the work center is located and a key which identifies the work center.

4. If you are creating a work center, you now have to enter the work center category. Choose Enter and enter a short description of the work center [Page 26] on the next screen.

   If you change data of a work center that is assigned to an operation, only those default values [Page 27] for which a reference indicator [Page 28] has been set, are changed in the operation. The data in the operation is brought up-to-date the next time the task list is called up.
Creating and Changing Work Centers by Copying

Prerequisites

When you are creating or changing a work place, you can copy data from an existing work center. The selected data that is copied from the existing work center overwrite any data that has already been entered. Afterwards you can change this data.

Procedure

1. Enter the plant and the key which identifies the work center that you want to use as a reference. Choose Enter.

   If you are already in one the work center views choose Edit → Copy from and specify the reference.

   The Copy from dialog box appears.

2. Select the data you wish to transfer.

3. Choose Copy.

   If you change a work center that is assigned to an operation, only the default values [Page 27] that have the reference indicator [Page 28] set are also changed in the operation.
Checking Work Centers

Prerequisites
You can check which work center views you have not edited. This is useful for instance, if you have stopped editing a work center before you have completed all the views.

Procedure
From any of the work center views choose Work center → Check.
You then reach the views you have not yet edited.
Renaming Work Centers

Prerequisites
You can rename a work center, in other words give it a new key. The new key is then automatically used in all the applications where the work center is used.

Procedure
1. From the work center area menu choose Work center → Rename.
2. The dialog box New name is displayed.
3. Enter the new key for the work center.
4. Choose Enter.
5. If you do not want to change any other data choose Save.
Locking and Unlocking Work Centers

Prerequisites
If you want to prevent a work center being used, you can lock it. If you then try to use a locked work center in a routing or work order, you will receive a warning from the system. If you want to use it again, you can remove the lock.

Procedure
In the Basic data view choose Extras → Status → Lock/unlock.
Deleting Work Centers, Setting Deletion Flags

Prerequisites

You can only delete a work center if it is not in use. You cannot delete work centers that are used in objects, which have been logically deleted but are still in the database (for instance operations). A deleted work center cannot be archived, since it is no longer in the database.

If a work center is still in use, you can mark for deleting by setting a deletion flag. A work center with a deletion flag can no longer be assigned. You can however remove the deletion flag. You do not need to set a deletion flag to archive or delete a work center.

Procedure

Deleting

From the Basic Data view in the Change work center screen choose Work center → Delete.

Setting and removing deletion flags

From the Basic Data view in the Change work center screen choose Extras → Status → Deletion flag.

💡

You can use deletion flags as a selection criterion for the work centers to be deleted in the next reorganization run.
Classifying Work Centers

Prerequisites

In order to allocate a work center to a class, the class must first be defined in the class system. For more information, see Creating Classes [Page 20]

One class type is the system default. If several class types are available for a work center, you can change the class type.

Procedure

1. While you are creating or editing a work center choose Extras → Classification.
2. Enter the class you wish to allocate to the work center.
3. To maintain characteristics choose Edit → Values.

💡

You can also allocate a work center to a class in the area menu Classification:

1. In the R/3 main menu choose Logistics → Central functions → Classification.
2. Choose Allocation → Maintain → Object to classes.
Creating Classes

1. In the R/3 main menu choose Logistics → Central functions → Classification.
2. Choose Class → Create.
3. Enter the necessary data.

For further information, see the R/3 Library Cross Application (CA) under Classification Guide.
Assigning Work Centers to Subsystems

Prerequisites
You can transfer work center data to a subsystem (external application) for plant data collection (PDC) by entering the subsystem within work center maintenance.

Procedure
1. From the Basic Data screen in the work center choose Extras → Subsystem link.
   The dialog box Subsystem grouping is displayed.
2. Enter the subsystems to which the work center data should be sent.
Archiving Work Centers

Prerequisites

You can use the archiving object PP_WKC to archive and delete data from work centers and the capacities assigned to work centers.

You can archive and delete work centers in an archiving session regardless of whether a deletion flag has been set or not.

The system does not delete after archiving in the following cases:

- Work centers used in objects (such as operations) that have been logically deleted but are still in the database.
- Pooled capacities and reference capacities

You can change the parameters for archiving sessions in Customizing under Cross-application components → General application functions → Define control parameters for archiving sessions.

For further information see the R/3 Library under Cross-application components → Application data archiving and reorganization.

Procedure

From the work centers menu choose Extras → Archiving.
Basic Data

In the Basic data screen you enter various administrative data, such as the person responsible and the location of the work center.

For standard values [Page 25] enter the standard value key [Page 25] and maintain the key for performance efficiency rate [Page 24]. Standard values themselves are maintained in the operation in the routing, after you have assigned the work center to the operation.
Performance Efficiency Rate Key

Performance efficiency rate keys are assigned in the Basic data screen of the work center to the standard values [Page 25]. The performance efficiency rate key is the ratio between an individual’s actual output and the planned average output.

Internally a reference indicator [Page 28] is set for the performance efficiency rate key. This means that the performance efficiency from the work center is transferred to the operation and cannot be changed there. If you do not enter a performance efficiency rate key, the system assumes 100% efficiency.

The standard values in routings are always based on a performance efficiency of 100%.

You define performance efficiency rate keys in Customizing for Work centers by choosing Define key for performance efficiency rate.
Standard value

**Standard values** are planned values for the execution of an operation and are maintained in the operation. Typical standard values are, for instance, set-up and processing. The execution time, costs and capacities are calculated in operations using formulas [Page 127] from the work centers and standard values from the operations.

When you assign a work center to an operation, up to six data fields and key words are assigned to the operation via the standard value key of the work center. The standard value key is defined in the Customizing for Work centers by choosing Standard value and is entered in the Basic data screen of the work center.

The rules for maintenance for standard values in the work center Basic data screen determine whether you have to maintain standard values in the operation or whether this is optional.

You can enter default units of measure for the standard values in the work center screen Default values. For inhouse-production operations the default value for the unit of measure of work is maintained in the screen Scheduling.
Creating a Short Text Description of the Work Center in Different Languages

1. While maintaining the work center in the Basic data screen choose Extras → Short texts. The dialog box Short Texts appears.
2. Choose New entries.
3. Enter the language and short text.
   If you want to enter a long text, choose Long text.
4. Choose Continue.

💡

The short text in the original language cannot be deleted.
Default values

You can enter **default values** for operation and sub-operations in work centers. The default values are then copied when you assign the work center to the operation or sub-operation.

By entering default values you reduce the effort necessary in editing operations, since the values are stored centrally and you do not need to enter them in each operation.

Default values in work centers are for instance:

- Wage type and wage group
- Control key [Page 29]
- Standard text key [Page 30]
- Suitability
- Setup type key
- Activity type [Ext.]
- Units for the standard values [Page 25]

You can use a reference indicator [Page 28] to determine whether the default values in a task list can be changed.

Most default values are edited in the *Defaults* view. The default values for the activity type and for the key for performance efficiency rate [Page 24] are edited in the Assignments and Basic data views respectively.
Reference Indicator

You can set a reference indicator for each default value [Page 27] in a work center and thus specify that the default value is referenced in the task list. This means that:

- The default value can only be changed in the work center and not in the task list.
- A change in the work center is automatically transferred to the task list, when the task list is called up.

If you remove the reference indicator in the work center, you can then change default values in the task list.

⚠️

If you change data in the work center, only the data with a reference indicator is changed in the task list. The data in the operation is brought up-to-date the next time the task list is called up.

💡

A reference indicator is set internally by the system for keys of performance efficiency rate.
Control Keys

A control key uses the following keys and indicators to determine how an operation or a sub-operation is to be processed in a task list. Examples of such keys and indicators are:

**Scheduling**: If you set this indicator, the system carries out scheduling for an operation or it determines the earliest or latest dates for a sub-operation. If you do not set this indicator, the system does not schedule the operation or sub-operation, the system automatically sets the duration to zero.

**Capacity planning**: If you set this indicator, the system creates capacity requirement records for the operation or sub-operation. If you set this indicator for a control key, you must also set the scheduling indicator.

The system only creates capacity requirements if you have set the **capacity planning** indicator and maintained the corresponding formulas [Page 127].

**Costing indicator**: Use this indicator to specify whether the operation or the sub-operation should be costed.

**Confirmation**: Use this indicator to specify whether and how the operation or sub-operation should be confirmed.

**Time tickets**: Use this indicator to specify that time tickets are printed for the operation or sub-operation.

**Print operation**: Use this indicator to specify that shop papers are printed for the operation or sub-operation.

**External processing**: Use this indicator to specify that the operation or sub-operation is to be performed by a third party. In this case, a purchase requisition is generated during order creation.

The control key is defined in Customizing for the **Work center** or for the **Routing**.
Standard Text Keys

You can use the **standard text key** while you are editing a work center in the *Default values* view to suggest a standard text for an operation or sub-operation. This text has previously been entered for a description that is frequently repeated. You can change the standard text [Page 31]

💡

The reference indicator [Page 28] refers only to the standard text **key** and not to the standard text itself.

The standard text key is entered in Customizing by choosing *Maintain standard text key*. 
Editing Standard Text

1. In either the work center area menu or the routings area menu choose Extras → Standard text.
   
   The Standard text: Initial screen appears.

2. Enter the standard text key [Page 30] for the text you want to edit.

3. Choose Standard text → Create, change or display.
Capacities

Capacity is the ability to perform a specific task.

You distinguish between various capacities in a work center, such as labor or machines, by using the capacity category [Page 34]. In order to plan capacities in a more detailed manner, you can define individual capacities for each capacity, for instance in the capacity category Person 3 employees or in the capacity category machine 5 lathes.

The following data is entered in a capacity:

- the operating time
- the available capacity
- Formulas [Page 127] for calculating capacity requirements

Capacities can be entered and changed in work centers, but also independently. The system distinguishes between:

- Work center capacities
- Pooled capacities
- Reference capacities
- Default capacities

These various capacities are described in more detail in the following sections.

Work Center Capacity

A work center capacity is created in the work center and is directly assigned to the work center. You can however maintain the capacity separately.

For detailed capacity planning you can assign individual capacities [Page 65] to each capacity category in a work center. You can determine available capacities for the individual capacities. Alternatively you can assign HR-objects [Page 96] (people, qualifications, requirements profiles and positions) to a capacity. You can thus determine which employee or qualification is needed in the capacity.

Apart from the available capacity and the assignments you can define other data in the work center for capacity planning, for instance

- Formulas for calculating the capacity requirements of various operation segments (setup, processing, teardown) or for internal processing.
- Key for the chronological Distribution of capacity requirements [Page 69] during operation execution or during internal processing.

Pooled capacity

A pooled capacity can be assigned to several work centers. It is created and edited independently of the work center. This is useful if, for instance, a group of employees works in several work centers.

Just like work center capacities, for more detailed capacity planning you can assign HR-objects [Page 96] to pool capacities and so prescribe a qualification or employee.
Reference Capacity

A reference capacity is used to simplify the maintenance of work center capacities. It is used to copy or reference an available capacity from. Reference capacities are created and maintained separately from work centers.

Default Capacity

A default capacity [Page 126] is also used to simplify data maintenance. You can define a default capacity for every capacity category in the plant in Customizing. It suggests a default value for the header data [Page 59] every time you create a capacity.
Capacity Categories

Capacities in work centers are distinguished by capacity categories. Capacity categories are for example:

- Machine capacity
- Personnel capacity
- Reserve capacity for rush orders
- Emissions
- Energy requirements

Each capacity category can be used once in each work center. For every capacity category you can maintain several available capacities (standard available capacity [Ext.] and available capacity versions [Ext.])

You define capacity categories in Customizing Work Centers under Define Capacity Categories.
Available Capacities

Definition

The productive working time of a capacity. If a capacity consists of several individual capacities: The productive working time for an individual capacity multiplied by the number of capacities. You can use a conversion factor to express an available capacity in another unit, for example tonnes.

The productive working time is also called operating time in the R/3 system.

Use

The active version is used for scheduling and capacity planning.

Structure

Operating Time

The available capacity is always expressed with reference to a day or a shift. You enter:

- Work start and work finish
  - That is, at what time work starts and when it finishes.
- Breaks
  - The time during working time that is taken up by breaks.
- Rate of capacity utilization
  - The working time that remains after breaks can only be used productively up to a certain percentage (for example, due to organizational disturbances). This percentage is known as the rate of capacity utilization.
- The number of individual capacities, that the capacity consists of.

The system calculates the operating time as:

$$\text{Operating time} = (\text{Working time} - \text{Break time}) \times \text{Capacity utilization rate/100\%}$$

The available capacity is then:

$$\text{Available capacity} = \text{Operating time} \times \text{number of individual capacities}$$

The graphic below illustrates the relationships between these parameters.
Available Capacities

Standard Available Capacity

In the simplest form you enter available capacities as standard available capacities. The validity period of a standard available capacity is not limited. The same capacity is available on every working day of the factory calendar. It is not possible to distribute the available capacity to several shifts.

Available Capacity Versions

If a standard available capacity does not satisfy your requirements, create an available capacity version and activate it. It is then used (instead of the standard available capacity) for scheduling and capacity planning.
Standard Available Capacity

Definition

Available capacity of a capacity category that is valid indefinitely as long as an interval of available capacity has not been activated.

Use

The system use standard available capacity, for example, for calculating execution time in a routing without reference to an order.

You use a standard available capacity if you do not want to describe your available capacity to the last detail. If, however, you want to scheduling and capacity planning to calculate with available capacities that are exact down to individual shifts, you must use available capacity versions.

Structure

A standard available capacity is indefinitely valid, the same capacity is available on every working day in the factory calendar (see graphic, working days are marked black on the axis).
Available Capacity Versions

Definition

Available capacity that, if it has been activated, is used instead of the standard available capacity for scheduling and capacity planning.

Use

You use available capacity versions, if you want to describe available capacities that differ from the standard available capacity. For example, you use available capacity versions, if the available capacity changes from day to day or if it is distributed among several shifts.

You create available capacity versions in Customizing.

Structure

Initially an available capacity version is the same as the standard available capacity. However when you create an interval of available capacity in the available capacity, the standard available capacity is replaced by the available capacity version.

The graphic illustrates an available capacity version that was created in two intervals of available capacity. The validity period of interval 1 is from January 6 to January 10, of interval 2 from February 15 to February 22.
Available capacity version with two intervals of available capacity
Interval of Available Capacity

Definition

Available capacity in an available capacity version that replaces the standard available capacity for a certain period.

Structure

 Capacities in an interval of available capacity are only available on the working days in the validity period. You can override the factory calendar with the Workdays indicator and specify that:

- Every day is a work day
- No day is a work day

In an interval of available capacity the same capacity is available on every workday (interval with a cycle duration of 1 day) or every workday in the week has its own available capacity (interval with a cycle duration of 7 days).

For instance, if you have a cycle duration of 7 days, the available capacity for Monday could be 8 hours. This means that on every Monday in the validity a capacity of 8 hours is available. In contrast, the available capacity on Tuesday could be 6 hours.

You can distribute the available capacity in interval over several shifts.
Example: Interval of Available Capacity with a Cycle Duration of 1 Day

In the graphic is an available capacity, in which you have created an interval of available capacity that is valid from January 6 to January 22. The same capacity is available on every workday (cycle duration 1 day). As workdays you have defined the workdays of the factory calendar using the workdays indicator. Outside the validity period the standard available capacity is available.

Available capacity version with interval of available capacity (1 day cycle)
Example: Interval of Available Capacity with a Cycle Duration of 7 Days

In the graphic is an available capacity, in which you have created an interval of available capacity that is valid from Wednesday, January 6 to Friday, January 22. You have used the Workday indicator to specify that every day is a workday. Different capacities are available on different days of the week (7 day cycle).

**Available Capacities**

<table>
<thead>
<tr>
<th>Day of the week</th>
<th>Available Capacities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monday to Thursday</td>
<td>24 hours</td>
</tr>
<tr>
<td>Friday</td>
<td>16 hours</td>
</tr>
<tr>
<td>Saturday and Sunday</td>
<td>8 hours</td>
</tr>
</tbody>
</table>

Outside the validity period the standard available capacity is available.
Example: Interval of Available Capacity with a Cycle Duration of 7 Days

Available capacity version with interval of available capacity (7 day cycle)
Shifts

The available capacity [Ext.] of a shift is defined by the following data:

- Shift start, shift end, break times
- Capacity utilization rate
- Number of individual capacities

Shift start, shift end and break times can be manually maintained in intervals of available capacity [Ext.].

You can however also use shift definitions and shift sequences [Page 45], which you define in Customizing the Work center under Define shift sequence for all your work centers.

Rules for Shift Sequences

- Shifts cannot overlap.
- The last shift of a day must start before midnight. It can end after midnight.
Example: Interval of Available Capacity with Shifts

In the graphic is an available capacity, in which you have created an interval of available capacity that is valid from Wednesday, January 6 to Friday, January 22. You have used the Workday indicator to specify that every day is a workday. Different capacities are available on different days of the week (7 day cycle).

Available Capacities

<table>
<thead>
<tr>
<th>Day of the week</th>
<th>Shift</th>
<th>Available Capacities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monday to Thursday</td>
<td>1</td>
<td>8 hours</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>8 hours</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>8 hours</td>
</tr>
<tr>
<td>Friday</td>
<td>1</td>
<td>8 hours</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>8 hours</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>0 hours</td>
</tr>
<tr>
<td>Saturday and Sunday</td>
<td>1</td>
<td>8 hours</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>0 hours</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>0 hours</td>
</tr>
</tbody>
</table>

Outside the validity period the standard available capacity is available.
Available capacity version with interval of available capacity (7 day cycle)
Shift Definition and Shift Sequence

You can define shift definitions and shift sequences for all your work centers in Customizing the work center under Define shift sequence. This is useful for maintaining available capacities.

- **Shift definition**
  In a shift definition you define the shift start, shift end, break times and the validity period.

- **Shift sequence**
  You define how shifts follow another on a daily basis for the duration of a cycle in a shift sequence. You can use shift definitions.

If you change the working times or the shifts, you do not have to change the available capacities of the work centers affected, but only the corresponding shift definitions or the shift sequence. The system changes the available capacity automatically.

The following graphic illustrates the principle of shift definitions and shift sequences.

![Shift Definition and Shift Sequence Diagram](image)
In Logistics you can reference daily work schedules from the personnel system (HR). If a referenced daily work schedule is changed in HR, the changes will effect logistics directly.
# Maintenance of Available Capacities

## Purpose

In this process you maintain the available capacities for work centers.

## Prerequisites

You have assigned the capacities, whose available capacities are to be maintained to the work center already. You have also entered the general data for these capacities.

## Process flow

Proceed as follows for every capacity in the work center:

1. As required reference or copy an available capacity that already exists.
   - If you are referencing an available capacity, you can only work directly in the referenced capacity. Continue as in step 4.
   - If you copy an available capacity, you can edit this copy. Continue as in step 2.

2. Maintain the standard available capacity for the capacity.

3. Maintain available capacity versions for the capacity. Proceed as follows for each interval of available capacity in an available capacity.
   - Edit the general interval of available capacity data. Specify whether it should have a one day or seven day cycle period. Edit the general data of the interval of available capacity. Specify whether it should have a one day or seven day cycle period.
   - b) Edit the shifts in the interval of available capacity. Proceed as follows for every day of the cycle:
     - I) Specify the number of shifts.
     - II) Edit the data of the shifts.

4. If you want to use this version in scheduling and capacity planning, activate this version.
Maintenance of Standard Available Capacities

Prerequisites
You have assigned the capacities, whose standard available capacity is to be maintained, to the work center already. You have also entered the general data for these capacities.

Process flow
1. In the work center area menu choose Goto → Capacity → Overview.
   The Capacity Overview screen appears.
2. Place the cursor in one of the fields of the capacity, whose standard available capacity you want to maintain and choose Goto → Capacity → Header.
   The header screen appears
3. Edit the date in the Standard available capacity detail screen.
4. Save the work center.

If an available capacity version is active, the system uses it instead of the standard available capacity. You can recognize whether a version is active from the Active version field in the Header screen. If you want the system to use the standard available capacity, delete this entry.
Maintenance of Available Capacity Versions

Use

You use this function to edit available capacity versions or alternatively the elements they comprise of, intervals of available capacity and shifts.

Prerequisites

You have assigned the capacities, whose available capacity versions are to be maintained to the work center already. You have also entered the general data for these capacities.

Features

The Intervals and shifts screen contains

- General data on the work center, capacity and available capacity version
- A Default line that simplifies maintenance of shifts
  
  If you cannot change an available capacity (perhaps it is referenced) the system hides the default line.

- A table that lists the intervals and shifts.

<table>
<thead>
<tr>
<th>Information about</th>
<th>can be found in</th>
</tr>
</thead>
<tbody>
<tr>
<td>General topics</td>
<td>General functions [Page 50]</td>
</tr>
<tr>
<td>Maintaining intervals of available capacity</td>
<td>Maintaining intervals of available capacity [Page 51]</td>
</tr>
<tr>
<td>Maintaining shifts</td>
<td>Maintaining shifts [Page 54]</td>
</tr>
</tbody>
</table>

Activities

To reach the Intervals and shifts screen:

1. In the work center area menu choose Goto → Capacity → Overview.

   The Capacity Overview screen appears.

2. Place the cursor in one of the fields of the capacity, whose available capacity versions you want to maintain and choose Goto → Capacity → Header.

   The header screen appears.

3. Choose Goto → Intervals and shifts.
General Functions

Use

You use these functions in the Intervals and shifts screen for navigation and making general settings.

Activities

<table>
<thead>
<tr>
<th>What do you want to do?</th>
<th>Proceed as follows:</th>
</tr>
</thead>
</table>
| To find the available capacity valid on a particular data and edit it.               | 1. Choose *Extras → Goto date.*  
2. Enter the date and choose *Continue.*  
   The available capacity valid on the date is displayed.                                                                                 |
| To move a particular available capacity to the top position in the display.          | Select the available capacity and choose *Edit → Position.*  
The selected line is moved to the top.                                                                                                          |
| To maintain another capacity.                                                        | 1. Choose *Goto → Another cap. cat.*  
2. Enter the capacity category to maintain and choose *Continue.*  
   The available capacity for the selected capacity category is displayed and can be maintained.                                              |
| Hide all the shifts and display the operating times and available capacities for each interval. | Choose *Extras → View → Only intervals.*                                                                                                                                                                       |
| Display all the shifts, the operating times and available capacities for each interval. | Choose *Extras → View → Intervals and shifts.*                                                                                                                                                                  |
| Undo all the changes since the last save.                                            | Choose *Extras → Reset capacity.*                                                                                                                                                                               |
| Change the unit of measure for all intervals.                                        | Enter a new unit in the top line of the table and choose *Continue.*  
All the available capacities are displayed in the new unit.                                                                                     |
Maintaining Intervals of Available Capacity

Use

You use these functions in the Intervals and shifts screen, to maintain intervals of available capacity.

Activities

<table>
<thead>
<tr>
<th>What do you want to do?</th>
<th>Proceed as follows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include a new interval</td>
<td>1. Choose <em>Edit</em> → <em>Insert</em> → <em>Insert interval</em></td>
</tr>
<tr>
<td></td>
<td>A new input line for the interval appears. Rate of capacity utilization and Number of individual capacities can be copied from the default line.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the validity period and further data for the interval and choose <em>Continue</em>.</td>
</tr>
<tr>
<td></td>
<td>The interval is inserted. Existing intervals of available capacity that are overlapped by the new interval are overwritten where they overlap.</td>
</tr>
<tr>
<td></td>
<td>The system automatically inserts the number of shifts entered. In the case of 7 day cycles, this happens for every day of the week.</td>
</tr>
<tr>
<td></td>
<td>3. Edit the shifts in the interval of available capacity.</td>
</tr>
<tr>
<td>Copy an interval of available capacity</td>
<td>4. Select the interval that you want to copy and choose <em>Edit</em> → <em>Copy</em>.</td>
</tr>
<tr>
<td></td>
<td>A new input line for the interval appears.</td>
</tr>
<tr>
<td></td>
<td>5. Enter the validity period and further data for the interval and choose <em>Continue</em>.</td>
</tr>
<tr>
<td></td>
<td>The interval is inserted. Existing intervals of available capacity that are overlapped by the new interval are overwritten where they overlap.</td>
</tr>
<tr>
<td>Delete an interval of available capacity</td>
<td>Select the interval of available capacity to be deleted and choose <em>Edit</em> → <em>Delete line</em>.</td>
</tr>
<tr>
<td></td>
<td>The system deletes the selected line.</td>
</tr>
<tr>
<td>Delete all intervals of available capacity</td>
<td>Choose <em>Edit</em> → <em>Delete all intervals</em>.</td>
</tr>
<tr>
<td></td>
<td>The system deletes all the intervals of available capacity.</td>
</tr>
</tbody>
</table>
Displaying Intervals of Available Capacity

   
The Intervals Of Available Capacity screen appears. The intervals of available capacity [Ext.] for the current versions are displayed

2. Determine which available capacity version [Ext.] you want to display

3. If required, enter a date from which the available capacity should be displayed.
   
   If you do not enter a date, all the intervals of available capacity are displayed

You can now:

- Create intervals of available capacity [Ext.]
- Create intervals of available capacity [Ext.]
- Change the shift sequence in the interval of available capacity [Ext.]
- Maintain shifts [Ext.]
Maintaining Shifts

Use

You use these functions in the Intervals and shifts screen, to maintain shifts.

Prerequisites

You can only call up these functions, if you are in the *Intervals and shifts* view. If you are in the *Only intervals* view, change the view by choosing *Extras → View → Intervals and shifts*.

Activities

<table>
<thead>
<tr>
<th>What do you want to do?</th>
<th>Proceed as follows:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a shift to the shifts of a day</td>
<td>1. Select one of the shifts on the day to which you want to add the shift and choose <em>Edit → Insert → Insert shift</em>.</td>
</tr>
<tr>
<td></td>
<td>A new input line for the shift appears.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the data for the shift and choose <em>Continue</em>.</td>
</tr>
<tr>
<td></td>
<td>The shift is inserted.</td>
</tr>
<tr>
<td>Insert a shift sequence</td>
<td>1. Before you branch to this screen, enter the grouping in which the shift sequence is to be created.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the shift sequence in the relevant field in the interval of available capacity and choose <em>Continue</em>.</td>
</tr>
<tr>
<td></td>
<td>The shift sequence is included.</td>
</tr>
<tr>
<td>Insert a shift according to a shift definition</td>
<td>1. Before you branch to this screen, enter the grouping in which the shift definition was created.</td>
</tr>
<tr>
<td></td>
<td>2. Enter the <em>shift definition</em> in the relevant field in the shift and choose <em>Continue</em>.</td>
</tr>
<tr>
<td></td>
<td>The system copies the start and finish times as well as the break duration from the shift definition to the shift. If you want to change this data later, delete the entry in the <em>Shift definition</em> field.</td>
</tr>
<tr>
<td>Create a shift for a day of the day of the week that does not have a shift</td>
<td>Select a shift in the previous day of the week and choose <em>Edit → Insert → Insert day</em></td>
</tr>
<tr>
<td></td>
<td>The system inserts a new line for a new shift on the day required.</td>
</tr>
</tbody>
</table>
## Maintaining Shifts

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete a shift</td>
<td>Select the shift and choose <em>Edit</em> → <em>Delete line</em>. The system deletes the selected shift.</td>
</tr>
</tbody>
</table>
| Select all shifts that have particular attribute. | 1. Enter the attribute (e.g. rate of capacity utilization 50%) in the default line.  
2. Select the relevant attribute column in the table and choose *Edit* → *Select default values*.  
3. The system selects all the intervals that have the required attribute. |
| Change a particular attribute for a large number of shifts. | 4. Select all the shifts that have the attribute (for example as above).  
5. Enter the new value for the attribute (in our example, a rate of utilization of 75%) in the default line.  
6. Select the relevant attribute column in the table and choose *Edit* → *Copy default values*.  
7. The system changes the attribute of all the selected shifts to the new value. |
| Hide all the shifts and display the operating times and available capacities for each interval. | Choose *Extras* → *View* → *Only intervals*. |
| Display all the shifts, the operating times and available capacities for each interval. | Choose *Extras* → *View* → *Intervals and shifts*. |
Activating Available Capacity Versions

Procedure

1. In the work center area menu choose Goto → Capacity → Overview.
   The Capacity Overview screen appears.
2. Place the cursor in one of the fields of the capacity, whose standard available capacity you want to maintain and choose Goto → Capacity → Header.
   The header screen appears
3. In the Active version field, enter the available capacity version that you want to activate.
4. Save your data.

Result

From now on the activated available capacity version is used for scheduling and capacity planning.
Displaying Available Capacity

Prerequisites

You can display available capacities as lists (available capacity profile) and as graphics.

In available capacity profiles up to three available capacity versions or capacity categories [Page 34] can be displayed, resolved down to a day.

You can display the available capacities in this list graphically, if the capacities all have the same unit of measure. You determine how the graphic is presented by entering the period type and period duration or the period pattern key [Page 77]:

- **Period type**
  The period type determines the shortest period of time for the presentation. You can choose between calendar days, working days, weeks, months and years. If you choose working days and you have entered a factory calendar, the working days in the factory calendar are used.

- **Period duration**
  The period duration determines how many units of the chosen period type are shown together in the graphic. For instance, if you enter period duration 4 and period type calendar days, the available capacity for four calendar days is displayed together.

Procedure

Displaying Available Capacity as a List

1. In the Intervals of Available Capacity screen [Page 59] Error! No bookmark name given. enter the capacity categories and version numbers of the available capacities you want to display.
   
   You can display up to three available capacities.

2. If necessary, enter another unit of measure for available capacities

3. If required, enter a date from which the interval of available capacity should be displayed.
   
   If you do not enter a date, all intervals are shown

4. Choose Enter.
   
   Using the list displayed, you can then display available capacities graphically.

Displaying Available Capacity Graphically

1. In the header screen [Page 59] choose Goto → Interval.
   
   The Time frame for period pattern and selections screen appears.

2. Enter either the period duration and period type or a period pattern key [Page 77].

3. Enter the period you want to see.

4. Choose Continue.
   
   a) The SAP Business Graphic appears. The available capacities from the available capacities profile are displayed in 3-D.
5. You can select how the graphic is presented by choosing Goto and then the required presentation type (2D-view, 3D-View, Overview).

For more information about SAP Business Graphics, see the R/3 Library BC Basis Components by choosing ABAP Workbench → SAP Graphics:
Maintaining Capacities

Capabilities can be created and edited in work centers (work center capacity) or independently (for example pooled capacities).

Capacity data is maintained on the following screens:

- **Capacity overview** (only for work center capacities)
- **Header**
- **Interval of available capacity**
- **Available capacity profile**

You can use **Goto** to switch between these screens.

As long as you do not save the capacity data, you can go back to the original state by **resetting a capacity**.

**Initial Steps - Work Center Independent Capacity**

1. In the **Work centers** area menu choose **Capacity → Create or Change**.
   
   The **Initial screen** appears.

2. Enter either a work center capacity (only possible in change mode) or a work center independent capacity.

3. Choose **Enter**.
   
   The **header** screen appears.

**Initial Steps - Work Center Capacity**

1. In **Work center maintenance** choose **Goto → Capacity → Overview**.

   The **Capacity Overview** screen appears.

**Capacity Overview Screen**

The **Capacity Overview screen** is only available in work center maintenance.

Here:

- **assign or delete capacity categories** to/from work center capacities
- You edit **formulas** for capacity categories so that the system can calculate capacity requirements
  
  If you do not specify a formula, no capacity requirements are calculated during capacity planning

- You maintain the **distribution key** for capacity requirements.

- You can assign pooled capacities to capacity categories, if required.
**Header Screen**

Here

- you choose the capacity category to edit by choosing *Goto → Another cap. cat.*
- you determine whether a work center independent capacity should be a *pooled capacity [Page 32]*
- you maintain the *standard available capacity [Ext.] and planning details [Page 73]* for capacity planning
- you maintain links to *individual capacities [Page 65]* or *HR objects [Page 96]*, for example people
- you determine the *active version [Ext.]* of the available capacity

**Interval of Available Capacity Screen**

Here

- you display *standard available capacities [Ext.] and existing intervals of available capacity [Ext.]*
- you can maintain further alternative available capacities in different *available capacity versions [Ext.], using intervals of available capacity [Ext.]*
- you change *shifts [Ext.] or shift sequences [Ext.]* in the intervals of available capacity
- you can determine the available capacity for a capacity by *cumulation [Page 75]* (only for work center capacities).

**Available Capacity Profile Screen**

Here

- the *available capacities [Ext.] of the various capacity categories [Page 34]* or *available capacity versions [Ext.]* are displayed as a list.
- you can *display graphically [Page 57]* the available capacities in a available capacity version
Creating Capacities by Copying from

Prerequisites

When you create a capacity, you can use an already existing capacity to copy from. You can use either a work center capacity or a work center independent capacity.

Procedure

Work Center Independent Capacity

1. On the initial screen [Page 59] for creating a capacity choose Copy from...
   The Copy from dialog box appears.

2. If you want to copy from a work center independent capacity (for example a pooled capacity), enter the capacity and the capacity category. If you want to copy from a work center capacity, enter the work center and the capacity category.

3. Select the data that you want to copy to the new capacity.

Work Center Capacity

1. On the initial screen [Page 59] for creating a work center enter the plant and the work center from which you want to copy.
   The Copy from dialog box appears.

2. Select the data that you want to copy to the new work center

   In work center maintenance and capacity maintenance you can either copy or reference capacities [Page 63].
Reference Available Capacity

If you want to maintain an available capacity [Ext.], you can transfer the following data from a reference capacity [Page 32]:

- the standard available capacity [Ext.]
- the active available capacity version [Ext.]

If no active version has been specified in the reference capacity, you can determine one.

When you create an available capacity for a work center, you can transfer the available capacity of another capacity category.

By either referencing or copying capacities, you determine how transferred data can be changed:

- **Copying capacities**
  
  You can change the transferred data. Changes to the reference capacity have no effect on the capacity.

- **Referencing capacities**
  
  You can only change the transferred data by changing the reference capacity.

Multi-level references: If you copy or reference capacity Y in capacity X and capacity Y copies from or references capacity Z, then the data for X is copied or referenced directly from Z.
Copy a capacity

   The Reference available capacity dialog box appears.
2. If you are creating an available capacity in a work center and want to refer to another capacity in the work center, just enter the capacity category.
3. If you are creating a capacity in capacity maintenance or want to refer to a capacity outside the work center, enter the name of the capacity and the capacity category.
4. Choose...
<table>
<thead>
<tr>
<th>Choose..</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Continue</td>
<td>reference the capacity</td>
</tr>
<tr>
<td>Copy</td>
<td>copy the capacity</td>
</tr>
</tbody>
</table>

April 2001
Assigning Pooled Capacities

Prerequisites

You can assign a pooled capacity [Page 32] to a work center.

Pooled capacities can only be created independently from the work center in capacity maintenance. If you want to make a work center independent capacity a pooled capacity, set the Pooled capacity indicator in the General data section of the screen and then choose Enter.

Procedure

Enter in the required capacity category in the capacity overview [Page 59] of the work center the name of the pooled capacity.

If the default capacity [Page 32] of a work station does not intend pooled capacities to be assigned, you can do this nonetheless:

1. Delete the capacity category by choosing Edit → Delete.
2. Create a new capacity category by choosing Edit → New entries.
Maintaining Individual Capacities

Prerequisites

Individual capacities are used in capacity planning for more detailed resource planning. For instance, you can divide a machine capacity into several individual machines and maintain an available capacity for each machine. Capacity requirements can then be distributed among the individual capacities. If you do not maintain an available capacity for an individual capacity, it is calculated from the operating time of the capacity to which the individual capacity has been assigned.

Individual capacities have the same capacity categories as the capacities to which they are assigned.

In order to be able to create individual capacities the CapCatPers indicator for the capacity category must not be set in Customizing.

Procedure

Assigning Individual Capacities

1. On the header screen choose Goto → Individual capacities.
   The Assignments to Individual Capacities screen appears.
2. Define the individual capacities

Maintaining Available Capacities for Individual Capacities

1. In the Assignments to Individual Capacities screen place the cursor on the individual capacity whose available capacity you want to maintain.

   If the Maintnd indicator has been set, then an available capacity has been maintained for this individual capacity.

2. Choose Edit → Choose.
   a) The header screen appears.
3. Enter the capacity data for the individual capacity
Resetting a Capacity

Prerequisites

If you are changing capacity data and wish to reset the data to its original state, you can do this as long as you have not saved the data. This is useful, for instance, if want to change data for test purposes in capacity planning.

Procedure

In the header screen [Page 59] choose Extras → Reset capacity
Assigning or Deleting Capacity Categories in Work Centers

Assigning Capacity Categories
In the capacity overview [Page 59] choose Edit → New entries.

Deleting capacity categories
In the capacity overview [Page 59] choose Edit → Delete.
Choosing Units of Measure for Available Capacities

1. In the header screen [Page 59] choose Extras → Units of measure
   The Conversion of Units of Measure screen appears
2. Enter the data for converting to the new unit of measure [Ext.].
Distribution Key - Distributing Capacity Requirements

The chronological distribution of capacity requirements over the duration of an operation depends on the capacity category.

The personnel capacity of a set-up person is required at the beginning of an operation and the machine operator perhaps every four hours to check up on progress, but the machine capacity is required constantly during the whole operation.

The distribution of capacity requirements in capacity planning is controlled by distribution keys. You can enter and edit the following distribution keys in the Capacity overview screen [Page 59]:

- Distribution of the capacity requirement in the set-up, processing and teardown operation segments (for instance in production orders)
- Distribution of the capacity requirement for internal processing (for instance in networks and maintenance orders).

Distribution keys are defined in Customizing for Work centers by choosing Define distribution key.

For more information about distributing capacity requirements, see the R/3 Library PP - Capacity Planning.
General Capacity Data

You can enter or edit the following data in the General data section of the header screen [Page 59]:

- **Planner group**
  The capacity planner group is responsible for maintaining and planning capacities. It is defined in Customizing for the work center by choosing **Determine capacity planner**.

- **Pooled capacity indicator**
  The pooled capacity indicator tells you whether the capacity is a pooled capacity, and thus be assigned to several work centers. Pooled capacities can only be created independently from work centers.

- **Grouping**
  In Customizing you can create **shift sequences or shift definitions** [Page 45] for groupings, that is for special areas (for instance different plants or part of a plant). When you maintain available capacities you can then select the shift definitions and shift sequences that have been maintained for the grouping.
Setting Up determination of Actual Capacity Requirements

Prerequisites

In this procedure you determine if and how actual capacity requirements are determined from the confirmation of activities or quantities.

The system determines actual capacity requirements from

- **Activities** by equating every actual capacity requirement to an activity.
- **Quantities** by using formulas to determine the corresponding capacity requirements. You must have entered these formulas on the Capacities tab page.

See also: Display of actual capacity requirements [Ext.] in PP Capacity Planning.

Procedure

1. On the Capacities tab page of the work center select a capacity category to determine the actual capacity requirements for.

2. Choose Extras → ActlCapReqmts.
   The Settings for determining the actual capacity requirements dialog box appears.

3. Set the Calc. actual cap. reqmts. indicator.

4. If the actual capacity requirements are to be determined from the activities, enter an activity for each actual capacity requirement in the Actual capacity requirements from activities detail screen. Enter the standard value parameters to identify the corresponding activity.

   You can display the standard value parameters for work centers via the value help.

5. Save the work center.
Example: Assigning Activities to Actual Capacity Requirements

Your work center has two capacity categories - *machine* and *labor*. Four activities are confirmed for operations that are executed at this work center (setup time, processing time, teardown time and labor time).

You want to equate the actual capacity requirements Setup (or Teardown) with the activity Setup time (or Teardown time). The actual capacity requirement Processing should

- equated to the activity Processing time for capacity category Machine
- equated to the activity Labor time for capacity category Labor

These assignments are illustrated in the graphic.
Planning Details for Capacity Planning

In the *Planning details* section of the header screen [Page 59] you determine how capacity data is used in the work center for capacity planning:

- **Relevant to finite scheduling indicator**
  You set this indicator to determine that the availability and load of the capacity are taken into consideration during finite scheduling.

- **Can be used by several operations indicator**
  You use this indicator to stipulate that this capacity can be used by several operations. If an operation already uses part of the available capacity, other operations can only use the remaining capacity if this indicator has been set.
  
  If you set this indicator you can, for example, plan at the machine group level.

- **Long-term planning indicator**
  If you set this indicator, the capacity is taken into account during the determination of capacities and requirements during long-term planning. The basis for doing this is a planned production program.

- **Overload**
  You use this field to determine by how many percent the load on a capacity is allowed to exceed the available capacity (for instance, whether you allow working in breaks).
Cumulation of Available Capacities and Capacity Requirements

Use
If you want to look at the capacity situation of groups of work centers or production areas instead of the capacity situation of individual production work centers you must cumulate available capacities and capacity requirements.

Prerequisites
The cumulation of available capacities and capacity requirements takes place using work center hierarchies. You can use hierarchies to represent areas of a company according to your planning needs. You can define work center hierarchies in the area menu Work centers. You can find detailed information on work center hierarchies in the documentation PP - Work Centers.

Features
There are different cumulation functions available in capacity planning and in the work center:

- **Dynamic cumulation [Page 79]**
  This is the cumulation function in capacity planning. You can use this function to cumulate both capacity requirements and available capacities.

- **Static cumulation [Page 75]**
  This is the cumulation function in the work center. You can only use this function to cumulate available capacities. Of course, you can maintain “cumulated” available capacities manually in superior hierarchy work centers.

Activities
For performance reasons, it is recommended that for large hierarchies you statically cumulate available capacities in the work center at an early stage in capacity planning. Then you can access the previously cumulated available capacities in capacity planning and only have to dynamically cumulate the capacity requirements.

If the available capacities change then dynamic cumulation of available capacity during capacity planning is more up-to-date. You can also update the statically cumulated available capacities by carrying out the static cumulation again after a change in the available capacities.
Static Cumulation

Use

You can use static cumulation in work center maintenance to cumulate available capacities from hierarchy work centers to a superior hierarchy work center.

The meaning of cumulated available capacities for capacity planning is described in the section *Cumulation of available capacities and capacity requirements* [Page 74].

You can find an example of a work center hierarchy and of the cumulation of available capacities in the section *Cumulation of available capacities* [Page 81].

Features

You execute a static cumulation in the work center when processing a version of available capacity. This is how you determine the available capacity of this version of available capacity. The available capacity maintained to date is overwritten with the available capacity that was generated by the cumulation function.

You cannot carry out a cumulation in a work center that references a capacity since its available capacity can only be changed by changing the reference capacity.

You can specify on what level of the hierarchy in the branch of the hierarchy under the work center the available capacity is to be cumulated. On this hierarchy level the system groups together the available capacities of the active versions of available capacity with the same capacity category. The operating times of the work centers on the hierarchy level can be different; the longest operating time is used as the operating time.

The system carries out the cumulation per period for the period of time in question. You define this period of time using the start date and the *period pattern key* [Page 77]. The available capacity per period in the period split results from the averaging and addition of the available capacities of the subordinate work centers in this period.

The cumulation function also generates an available capacity for the period before and after the cumulation period.

- Before the cumulation period the standard available capacity of the capacity category that you are maintaining is valid.
- Following the cumulation period the cumulated available capacity of the last day of the cumulation period is valid.

Explosion stop

If the indicator *Explosion stop* [Page 113] is set for a work center in the hierarchy then its subordinate work centers are not taken account of in the cumulation. The hierarchy is exploded in the branch affected only as far as this work center.
Activities

You call up the static cumulation when maintaining the version of available capacity of a work center capacity with Extras -> Avail.cap via hier.

If a work center belongs to several hierarchies then you can store the cumulated available capacities using the various hierarchies in various versions of available capacity in the work center.

If the available capacity of a subordinate hierarchy work center changes, the cumulated available capacity does not change automatically. If necessary, carry out a static cumulation again.

💡

In capacity planning you can use dynamic cumulation [Page 79] to cumulate both available capacities and capacity requirements.
Period Pattern Key

Definition

A period pattern key identifies a length of time that comprises of any number of consecutive time segments. Each of these time segments consists of periods. The duration of a time segment is determined by the period type and the number of periods. Typical period types are calendar days or weeks.

Use

The period pattern key is used for:

- Displaying available capacities graphically [Page 57]
- Cumulation [Page 75] of available capacities using work center hierarchies in work center maintenance

It is created in Customizing for Work centers by choosing Define period pattern key.

Structure

In the following graphic you can see an example of a period pattern that has been defined using a period pattern key.

Cumulating available capacities using the period pattern key
In work center maintenance the available capacities of different capacities are cumulated in the work center hierarchy using the period pattern key. For each period in the time segment defined by the period pattern key, the available capacities are averaged and added together.

In the graphic the available capacities A and B are cumulated in the available capacity C.

You are recommended to use shorter times for the first segments and longer ones for segments that are further in the future. Then you only need a limited number of periods, but have detailed information for the near future.
Dynamic Cumulation

Use
You can use dynamic cumulation in capacity planning to cumulate available capacities from hierarchy work centers to superior hierarchy work centers.

You can only carry out a dynamic cumulation in those parts of capacity planning where capacity requirements and available capacities are represented per period, for example in the capacity evaluation or in the tabular version of the planning table in capacity leveling.

💡

The meaning of cumulated available capacities and capacity requirements for capacity planning is described in the section Cumulation of available capacities and capacity requirements [Page 74].

You can find an example of a work center hierarchy and of the cumulation of available capacities in the section Cumulation of available capacities [Page 81].

Features

In a dynamic cumulation the system cumulates the available capacities and the capacity requirements for all capacity categories of the work centers that you have selected for capacity planning and that belong to the hierarchy specified. The cumulation is carried out for the whole of the evaluation period on the basis of the period pattern specified.

The cumulated available capacity and the cumulated capacity requirements for a capacity category at a work center are a result of the combination of available capacities and capacity requirements for the same capacity category at the lowest level in the relevant part of the hierarchy branch.

If the indicator Explosion stop [Page 113] is set for a work center in the hierarchy then its subordinate work centers are not taken account of in the cumulation. The hierarchy is exploded in the branch affected only as far as this work center.

Cumulating available capacities

When cumulating the available capacity, the system summarizes the available capacities in the active capacity version into one available capacity and writes it to the active version of the corresponding capacity category in the superior work center. The operating times of the subordinate work centers can be different; the longest operating time is copied to the capacity version for the superior work center as the operating time.

Cumulating capacity requirements

If capacity requirements have already been assigned to a capacity at a hierarchy work center, in which capacities are cumulated, then these are added to the cumulated capacity requirements.

If you have assigned a pooled capacity to several hierarchy work centers the total capacity requirements for the pooled capacity for every hierarchy work center.

Distribution according to operating time when cumulating

In the capacity evaluation, the system, when distributing according to operating time, distributes the capacity requirements of each operation according to the operating time of the corresponding
subordinate work center, before it cumulates the capacity requirements of the operations in the superior hierarchy work center.

To ensure that the system executes the distribution during cumulation in the same way in Capacity leveling with the capacity planning table and in the Extended evaluation, you must set the Hierarchy explosion indicator in the selection profile. If you do not set the indicator, the system distributes the capacity requirements for an operation according to the operating time of the subordinate work center. For further information, see Distribution of capacity requirements [Ext.].

Activities

You can make all the settings for the dynamic cumulation:

- In the evaluation profile [Ext.] for capacity leveling and the extended evaluation
- In the options profile [Ext.] for the capacity evaluation

You can specify whether you want to cumulate available capacities or capacity requirements or both using the hierarchy specified. If you want to work with cumulated data you should cumulate both the capacity requirements and the available capacities. You can create cumulated available capacities in the work center at an early stage in capacity planning using the static cumulation [Page 75]. Then you only need to cumulate the capacity requirements dynamically in capacity planning.

When calling up the capacity evaluation, the extended evaluation or capacity leveling, the system cumulates the available capacities and capacity requirements according to your settings.

During the capacity evaluation, you can also execute a dynamic cumulation of the capacity requirements or available capacities using a hierarchy of your choice by choosing Settings → General. You can also display a hierarchy with Hierarchy graphic.
Cumulation of Available Capacities

If you want to look at capacity load of production areas in capacity planning rather than at the load of specific work centers then you can represent the areas of the business that are relevant to planning in work center hierarchies. You can then cumulate the available capacities and capacity requirements.

The following graphic displays an example of cumulating available capacities.

Cumulating available capacities in a work center hierarchy

In this graphic the following cumulations are carried out:

- The available capacities “labor” in work centers center 3 and center 4 were cumulated one hierarchy level higher to the work center work center group 2. No cumulation was carried out in this work center for the capacity categories “machine” and “transport” because these capacity categories do not exist in work center group 2.

- The available capacities “machine” and “labor” in work centers center 1 and center 2 were cumulated one hierarchy level higher to the work center work center group 1. No cumulation was carried out in this work center for the capacity category “transport” because this capacity category does not exist in work center group 1.

- The available capacities “machine”, “labor” and “transport” for work centers center 1 to center 4 at the lowest level of the hierarchy were cumulated two hierarchy levels higher to work center lathe shop.
The system does not cumulate successively from one hierarchy level to the next. The available capacity of the work center *Lathe shop* for example, does not comprise the available capacities of the work centers *Work center group 1* and *Work center group 2*. 
Scheduling Data in Work Centers

You can enter the following scheduling data in work centers:

- **Scheduling basis**
  
  The scheduling basis is a capacity whose operating time is to be used for scheduling orders.

- **Formulas [Page 127]**
  
  You use formulas to calculate the execution times of operations in production orders using standard values, or to calculate the internal processing times in networks and maintenance task lists.

- **Interoperation times [Page 85]**

- **Dimension and units of measure for internal processing operations**
Maintaining Scheduling Data

1. From any work center screen choose Goto → Scheduling.
   The Scheduling screen appears.

2. Enter the capacity with its capacity category whose execution time you want to use for scheduling. This can be either a work center capacity or a pooled capacity.
   The capacity data must have already been entered in the work center.

3. Maintain formulas [Page 127] for operation segments (for production orders) or for internal processing time (for networks and maintenance orders).
   If you do not enter a formula for an operation segment, the execution time of this segment is set to zero.
   If you do not enter a formula for internal processing time, the duration in the network or maintenance order is used.
   Via Extras → Formula you can assign a formula constant [Page 140] a value and an unit, display a formula [Page 139] and test formulas [Page 139]

4. Maintain queue times [Page 85] and if necessary the dimension and units of measure for work in internal processing operations.
Interoperation Time

The interoperation time is the time between leaving one work center and beginning the operation at the next work center. It consists of the **move time** and the **queue time** before processing starts.

Enter the following data:

- **Work center location group**
  - Work centers that are in the same vicinity can be brought together in a location group. The planned values for move time between location groups are entered in a **move time matrix**.
  - The move time matrix is created in Customizing for **Work centers** by choosing **General data → Define move time matrix**.

- **Standard queue time**
  - Queue time that a workpiece normally waits before it is processed in the work center.

- **Minimum queue time**
  - Queue time that has to expire before work can continue on a workpiece. The minimum queue time replaces the standard queue time if the queue time is to be reduced for scheduling.

💡

- Work center queue times are only taken into consideration, if no queue times have been entered in the operation.
Costing

Use
You have to enter data for costing, if you want to cost the activities performed at the work center. Internal activities and business processes that are used when a product is produced at the work center can be settled to the product.

Integration
The data for costing is evaluated in the CO - Controlling application. You can find further information in the documentation for Product Cost Planning (CO-PC-PCP) under Work Centers in Costing [Ext.].

Features
A work center can
- use resources from a cost center
  In this case, the work center is linked to cost center accounting, which enables you to model the processes in your company according to responsibilities and functions.
  You can select activity descriptions from the following texts: Standard value key, activity types, in Customizing freely defined text (Production -> Basic Data -> Work Center -> General Data -> Standard Value -> Process Alternative Activity Descriptions).
  If you use integrated incentive wages and logistics, then here you can define from which incentive wage earner the corresponding activity type is displayed.
  You can find further information in the documentation for Cost Center Accounting (CO-OM-CCA)
- use resources from a business process
  In this case, the work center is linked to Activity based controlling, which enables you to model the processes in your company according to activities in a cross-function manner.
  You can find further information in the documentation for Activity-Based Costing (CO-OM-ABC), particularly under Method of Quantity Consumption (Pull) [Ext.].

Costing data is always entered for a certain validity period. Data that you have already entered for another validity period is overwritten.
Costing with Cost Centers

Prerequisites

The cost center that you want to assign the work center to, must exist already and belong to the same controlling area as the work center plant.

Features

For any one validity period you can assign a work center to only one cost center.

You can assign several work centers in different plants to one cost center. The work centers must belong to the same company code as the cost center.

You can assign an activity type, which is valid for the cost center, to every standard value in the work center. The activity type appears in the routing as a default value. You can prevent this default from being changed in the routing by setting the reference indicator.

Activities

You enter the following data (see red arrows in the graphic):

- The cost center and the validity period
- For every standard value a formula key and an activity type.

The system calculates the activity quantities from the formulas and the standard values. CO Controlling can then evaluate these using the activity prices.
Example: Costing with Cost Centers
Example: Costing with Cost Centers
The “Production” cost center has been assigned three activity types. Each activity type was valuated with an activity price. In this example, a setup hour (SET) costs $100.

Since the work center is assigned to a cost center, the activity types (as long as permissible in the cost center) can be assigned to standard values in the work center. In this example the activity types SET, MAC and LAB are assigned to the standard values “Setup”, “Machine” and “Labor” in the “Milling machine” work center. These activity types are defaults in all the operations that are executed at this work center.

In the work center a formula can also be assigned to each standard value for costing. Formulas are used to calculate activities for the general operation data (here operation quantity) from the general operation data and the standard values.

The prices for these activity quantities are calculated using the activity prices.
Assigning a Work Center to a Cost Center

Assigning a Work Center to a Cost Center

1. In work center maintenance choose Goto → Cost center assignment
   The Cost Center Assignment screen appears

2. Enter the validity period for the assignment.

3. Enter the cost center.

4. Assign the standard values (for production orders) or the activity type for internal processing (in the case of networks and maintenance task lists) to activity types and formulas for costing.

5. If you want to prevent an activity type from being changed in a routing, set a reference indicator [Page 28] for the activity.

6. Save the work center.
Costing with Business Processes

Use

You use this function so that a work center takes advantage of a business process.

Prerequisites

The formulas you use have been created in the Implementation Guide for the work center, under Capacity Planning → Work Center Formulas.

Features

You can assign a work center to a business process for a period. A work center can only be assigned to one business process for a period. The business process appears in the routing as a default value. You can prevent this default from being changed in the routing by setting the reference indicator.

You have to assign a formula to every business process. This formula is used to control the quantity-based use of the business process.

Be careful not to mistake these formulas for the formulas that are used in process cost allocation for process templates.

Activities

You enter the following data:

- The business process and the validity period
- A Cost center

The cost center entry is not processed further. If you have not assigned your work center to a cost center, you can enter a phantom cost center.
Assigning a Work Center to a Business Process

Prerequisites
The formula, the business process and the (phantom) cost center that you use, have already been created.

In the business process master data in the fields Allocation category and Actual allocation category, a business process that you want to assign to a work center can only have the indicator 1 or 2.

Make sure you enter an activity unit in the master data of the business process, that can be converted to the same units as the standard values in the routing.

Procedure
1. In work center maintenance choose Goto → Cost center assignment
   The Cost Center Assignment screen appears
2. Enter the validity period for the assignment.
3. Enter the cost center.
   This entry is only used for documentation. If you have not assigned your work center to a cost center, you can enter a phantom cost center.
4. Enter a business process and the corresponding formula key.
5. If you want to prevent a business process from being changed in a routing, set a reference indicator [Page 28] for the activity.
6. Save the work center.
Assignments to Objects in the Human Resource Management System (HR)

Definition
A work center or capacity in Logistics (LO) can be assigned to an object in the Human Resource Management System (HRMS). This could be, for example, a person or a qualification.

Use
The assignment of HR objects is used, for instance, to determine which employees or minimum qualifications are required for a work center (in logistics) or a capacity.

Structure
You have to enter a validity period for each assignment. A position or a person can only be assigned to one LO object (work center or capacity) at one point of time.

Assigning LO Work Centers to HR Objects
You can only assign LO work centers directly to either a HR organizational unit or a HR work center. If you link the LO work center to a HR work center, you can link the LO work center with the following HR objects:

- People
- Positions
- Qualifications
- Requirements profile

Assigning Capacities to HR Objects
You can assign HR objects, for example, people and positions to work center capacities and pooled capacities directly. They are not linked with HR organizational unit or HR work centers.

Integration
In order to link capacities or work centers in Logistics with HR objects, you must be using the Human Resource Management System.
Assigning HR Objects to Work Centers

Prerequisites
You can link work centers in logistics (LO) with the Human Resources Management System in two ways:

- If you want to assign the HR objects people, positions, requirements profiles and qualifications to LO work centers, you must first assign the work center to an HR work center. This can be an existing HR work center. You can also create a new HR work center (which can have the same name as the LO work center) during the assignment procedure.

- Alternatively you can assign a LO work center to an organizational unit in HR. You can then create no further links to other HR objects via the organizational unit.

You can delete links between an LO work center and HR.

Procedure

Linking a Work Center with HRMS

1. In work center maintenance choose Goto → HR assignment.

   If the work center is already linked to HR, the Organization structure screen appears and you can see the existing assignment. If this is an assignment to an HR work center, you can assign further objects (for example people) to the work center (see the next section - Assigning People, Positions or Requirements Profiles to Work Centers).

2. If you have not yet created a link from the work center to HR, decide whether you want to assign the work center to an HR work center or to an HR organizational unit, by selecting the relevant indicator.

3. Enter the name of the HR work center or organizational unit. If necessary you can create a new work center in HR by choosing HR work center.

   The Organization structure screen appears and you can assign HR objects, such as people or qualifications, via the HR work center to the LO work center.

You can delete assignments to HR by choosing Edit → Delete HR assignment.

Assigning People, Positions or Requirements Profiles to Work Centers

1. If you have not yet assigned the LO work center to an HR work center, do so now (see the previous section).

2. On the Organization structure screen select the HR object category (for instance person) that you want to assign to the LO work center and choose Edit → Create assignment.

3. Enter the name of the HR object and the validity period for the assignment, choose Copy.

Assigning Qualifications to Work Centers

1. If you have not yet assigned the LO work center to an HR work center, do so now (see the Linking a Work Center with HRMS section).

2. On the Organization structure screen choose Edit → Qualifications.
3. Choose Requirements → Create.
   a) The Select Qualification dialog box appears.
4. Select the required qualification and choose Copy.
5. If necessary edit the validity period and the characteristic value.
6. Choose Back.
7. Save the assignments.

**Result**

The HR object is assigned to the capacity.

On the Organization structure screen the following information is displayed about the assigned positions, people and requirements profile:

- The object key, which consists of
  - the object type (for example P for person)
  - the object ID
- The name of the object
- A description of the object
- The validity period of the HR object in HR
- The validity period of the assignment to the LO object

Apart from the description, you can hide or show fields in the View menu.

You can delete an assignment by choosing Edit → Delete assignment.
Assigning HR Objects to Capacities

Prerequisites

You can assign people, positions, qualifications and requirements profiles in the HR Management System to work center capacities and pooled capacities in Logistics (LO).

To be able to assign these HR objects to capacities, you must have previously set the CapCatPers (capacity category person) indicator for the capacity category in Customizing the work center.

Procedure

Assigning People, Positions or Requirement Profiles to Capacities

1. In the capacity overview screen of capacity maintenance choose Goto → HR assignments.
   The Assignments to HRMS Screen appears.
2. Select the type of HR object you want to assign and choose Edit → Create assignment.
3. Enter the name of the HR object and the validity period for the assignment.
4. Choose Copy.

Assigning Qualifications to Capacities

1. On the Organization structure screen choose Edit → Qualifications.
2. Choose Requirements → Create.
   a) The Select Qualification dialog box appears.
3. Select the required qualification and choose Copy.
4. If necessary edit the validity period and the characteristic value.
5. Choose Back.
6. Save the assignments.

Result

The HR object is assigned to the capacity.

On the Organization structure screen the following information is displayed about the assigned positions, people and requirements profile:

- The object key, which consists of
  - the object type (for example P for person)
  - the object ID
- The name of the object
- A description of the object
- The validity period of the HR object in HR
Assigning HR Objects to Capacities

- The validity period of the assignment to the LO object

Apart from the description, you can hide or show fields in the View menu.

You can delete an assignment by choosing Edit → Delete assignment.
Qualifications and Requirements Profiles

Definition

A qualification is knowledge or a capability. Several qualifications can be gathered together in a requirements profile.

Use

Qualifications are used to determine the suitability of employees for a work center.

Qualifications and requirements profiles are used in capacity planning to create a Hit List. An overall requirements profile is created from the qualification requirements in the work center, the operation and the capacity. Based on this overall profile, the hit lists display the suitability of the employees who have been assigned to the work center and the capacity category.

Qualifications and requirements profiles are edited in HRMS. For more information refer to the R/3 Library Personnel Planning and Development.

_requirements profiles are only used in Logistics. They should not be confused with Requirements subprofiles in HRMS.
Validity Periods

You can prescribe fixed validity periods for the following assignments to a work center:

- Cost centers
- People
- Positions
  - Qualifications
  - Requirements profile

Several people, positions or qualifications can be assigned to a work center in one period.

You can only assign one cost center to a work center in a period.
Technical Data for Calculating Standard Values with CAPP

The CAPP standard value calculation (CAPP - Computer Aided Process Planning) is a method for determining standard values. You can store data for CAPP standard value calculation in a work center.

Examples of such data are machine data, rounding categories and additional value keys. You also have to assign at least one process with which the standard values should be calculated to the work center.

For detailed information refer to the R/3 Library PP Standard values calculation with CAPP.
Assigning Processes

Prerequisites
If you want to use CAPP standard values calculation, you must assign at least one process with which the standard values should be calculated to the work center.

Procedure
1. In the Technical data screen of work center maintenance choose Extras → Process assignment.
2. Set the Std indicator (standard indicator) if the process should be used for automatic standard value calculation.
Work center hierarchy

Work centers can be grouped into a **work center hierarchy**. Apart from the top of the hierarchy - the hierarchy root - every work center in the hierarchy is subordinate to another work center.

One work center can exist in several work center hierarchies.

A work center hierarchy can include several plants.

Use of Work Center Hierarchies

Work center hierarchies are used in capacity planning to cumulate available capacity and capacity requirements.

You can cumulate available capacities from subordinate work centers to a superior work center level in order to determine the total available capacity for the superior work center.

In your factory you have several lathes. You create a higher-level work center, called "Machine center 3", which you use to cumulate the available capacity of several lathes.
Portraying Hierarchies

You can display a hierarchy in work center maintenance or hierarchy maintenance as a list or a graphic.

- **As a list**
  
  The work centers that belong to a hierarchy are listed together with their hierarchy level. Refer to Displaying Hierarchy Structure as a List [Page 111]

- **As a graphic**
  
  The hierarchy graphic displays the hierarchy as a tree. Refer to Calling up a Hierarchy Graphic [Page 108]

In work center maintenance you can only display the hierarchy structure, in hierarchy maintenance you can also edit the structure, for example you can delete or change work center assignment.
Hierarchy Creation

To produce a work center hierarchy you need to carry out the following steps:

1. You have to create the hierarchy [Page 105]
   You can only do this in hierarchy maintenance.

2. You then assign work centers to the hierarchy and arrange in the required order
   This you can do both in work center maintenance and hierarchy maintenance.

In Hierarchy Maintenance

You can assign work centers when you create or change a hierarchy. Refer to Creating Hierarchies [Page 105] and Assigning Work Centers in Hierarchy Maintenance [Page 107].

To arrange the work centers in the hierarchy, you have to call up the hierarchy graphic [Page 108]. You can display and edit the hierarchy.

In Work Center Maintenance

When you are creating or changing a work center, you can assign it to a hierarchy. To do so, you must either define it as the hierarchy root or enter the higher-level work center. Refer to Assigning work centers in work center maintenance [Page 106].

You can change the hierarchy level in the hierarchy graphic [Page 108] only, which you call up from hierarchy maintenance.
Creating Hierarchies

Prerequisites
You can only create a hierarchy in hierarchy maintenance. You can assign work centers to hierarchies in both work center maintenance [Page 106] and hierarchy maintenance [Page 107].

Procedure
1. In the work center area menu choose Hierarchy → Create.
   The Hierarchy screen appears.
2. Enter the plant and the name of the hierarchy.
3. Choose Goto → Header data.
   The Create Hierarchy: Header screen appears.
4. Enter a short description of the hierarchy.
5. Assign work centers to the hierarchy.

💡
For how you assign work centers to a hierarchy, see Assigning Work Centers in Hierarchy Maintenance [Page 107]
Assigning Work Centers in Work Center Maintenance

Prerequisites

In order to assign a work center to a hierarchy, you must have already created the hierarchy [Page 105].

You assign a work center to the hierarchy by either declaring the work center to be the root of the hierarchy or entering the superior work center.

You cannot change or delete an existing assignment to a hierarchy in work center maintenance. You can only do this in the hierarchy graphic [Page 108], which you call up from hierarchy maintenance.

Procedure

Displaying existing assignments

   The Hierarchy Relationships screen appears.
2. If you want to assign the work center to a further hierarchy, choose Edit → New entries.

Assigning a Work Center

   The Hierarchy Relationships Detail screen appears.
2. Enter the plant and the name of the hierarchy that you want to assign the work center to. Choose Enter.
3. If you want to define the work center as the uppermost level of the hierarchy, set the Root indicator.
   a) You can only do this if the hierarchy does not yet have a root.
4. Otherwise enter the plant and the name of the superior work center.
   a) If you do not make any entries about where the work center is positioned in the hierarchy, it will not be assigned to the hierarchy.
5. If necessary set the Stop explosion indicator [Page 113].
6. If you want to assign another work center, choose Work center → Another work center.
Assigning Work Centers in Hierarchy Maintenance

   If no work centers have yet been assigned to the hierarchy, the dialog box Choose work centers appears. If work centers have already been assigned, they are listed. Choose Edit → New assignments

2. Enter the plant where the work centers are, that you want to assign to the hierarchy.

3. You can restrict the selection of the work centers further by entering the relevant details.

4. Choose Enter.
   You return to the Create Hierarchy: Work center assignment screen:

5. In the screen section Assignments, select the work centers that you want to assign.
   If you do not select work centers, they will not be assigned.

6. If you want to assign more work centers, choose Edit → New assignments.

7. To position the work centers correctly in the hierarchy, choose Goto → Graphic.
   The hierarchy graphic appears, which you can edit. Refer to Connecting Work Centers [Page 109] and Deleting Work Center Assignments [Page 110]
Calling up a Hierarchy Graphic

Prerequisites

The hierarchy is presented in the hierarchy graphic as a tree diagram. You can call it up from both work center maintenance and hierarchy maintenance.

If you call up the hierarchy graphic from hierarchy maintenance, you can edit the hierarchy structure. To do this following functions are available:

- Connecting Work Centers [Page 109]
- Deleting Work Center Assignments [Page 110]

If you call up the hierarchy graphic from work center maintenance, you can only display the hierarchy graphic but cannot edit it.

You can change how the graphic is displayed (colors, partitioning, highlighting of selected objects) by choosing Settings.

Procedure

Calling up the hierarchy graphic from hierarchy maintenance

Choose Goto → Graphic.

You can now edit the hierarchy graphic

Calling up the hierarchy graphic from work center maintenance

1. Choose Goto → Hierarchy → Relationships or
   Goto → Hierarchy → Relationships detail.
2. Choose Goto → Hierarchy → Hierarchy graphic.
Connecting Work Centers

Prerequisites
You can position work centers in the hierarchy by connecting them in the hierarchy graphic.
To do this you must call up the hierarchy graphic from hierarchy maintenance. If you call the
graphic from work center maintenance, you can only display the hierarchy structure.

Procedure
1. In the hierarchy graphic [Page 108] choose Edit → Connect.
   The cursor is now displayed as a pencil.
2. Place the cursor on the superior work center.
3. Press the left hand mouse button and, keeping it pressed, move the cursor to the work
   center that you want to assign to a subordinate position.

You can only assign work centers to a superior work center, as long as they are not
already above the superior work center in the hierarchy. If you want to change the
order in a hierarchy in this manner, you must first delete the existing assignments.
Deleting Work Center Assignments

Prerequisites

You can delete work center assignments to a hierarchy in the hierarchy graphic.

To do this you must call up the hierarchy graphic from hierarchy maintenance. If you call the graphic from work center maintenance, you can only display the hierarchy structure.

Procedure

1. In the hierarchy graphic (Page 108) select the lower-level work center whose assignment you wish to delete.
2. Choose Edit → Split.
Displaying Hierarchy Structure as a List

Prerequisites
You can display work centers with their hierarchy levels in both hierarchy maintenance and work center maintenance.

You have the following display options:

- **Complete Display**
  The complete hierarchy structure from the root down to the lowest level is displayed.

- **Display from work center (explode from work center)**
  You can enter any work center, from which the hierarchy should be exploded.

- **Display from hierarchy root to explosion level (explosion level)**
  The hierarchy is displayed from the root down to a particular level.

The *explode from work center* and *explosion level* settings only affect the display. They do not affect capacity cumulation.

Procedure

**Complete Display**
Choose

- in the work center maintenance screens *Hierarchy relationships* or *Hierarchy relationships detail* the following path Goto → *Hierarchy* → *Structure*

- in hierarchy maintenance Goto → *Hierarchy structure*

All the work centers in the hierarchy are displayed together with their hierarchy levels.

**Display from Work Center**
1. Display the complete structure as above.
2. Choose *Settings* → *Start from*
   The *explode from Work Center* dialog box appears.
3. Enter the plant and the name of the work center.
4. Choose *Enter*.

**Display from hierarchy root to explosion level**
1. Display the complete structure as above.
2. Choose *Settings* → *Levels*.
   a) The *Set levels* dialog box appears.
3. Enter the number of levels.
4. Choose *Enter*.
Displaying Hierarchy Structure as a List

💡

You can also display hierarchy lists by choosing Reporting in the Work center area menu using the standard evaluations or you can search for work centers in a hierarchy using characteristics.
Explosion Stop

When you assign a work center to a hierarchy in work center maintenance, you can set the *Stop Explosion* indicator.

If this indicator has been set, then the explosion of the hierarchy during **cumulation of available capacity** will stop here. This is useful, for example, if you have entered available capacities and the available capacity of a work center should be larger than the sum of the available capacities from the subordinate work centers.
Reporting

Various forms of reporting are available for work centers in the work centers area menu.

Where-used Lists

Where-used lists show you in which task lists a work center is used or in which work centers capacities are used.

Change Documents

Change documents log changes to data elements in a work center. You can compile lists of change documents using various selection criteria.

Standard Reports

You can use standard reports to compile lists of work centers according to various criteria, for instance cost centers, capacity categories, or membership of a hierarchy.

User-defined Reports

If you want to, you can create your own reports in addition to the standard reports. You can use existing reports to copy from, for example report RCRA0010, which lists your work centers.

Use the following data for your own reports:

- Logical database: CR
- Application: C

For more information about writing reports see the R/3 Library BC ABAP Workbench under ABAP Reporting Tutorial.
Displaying Standard Reports

Prerequisites

You can use the following standard reports to produce lists of work centers according to various selection criteria, for instance cost center assignment or assigned capacity categories:

- Work center list
- Cost center assignment
- Work center capacities

You can also use the hierarchy name as a selection criterion for these reports.

You can use the standard report Work ctr hierarchy to list all the work centers in a hierarchy together with their respective hierarchy level.

Procedure

1. From the work centers area menu choose Reporting and then the required report.
2. Enter your selection criteria.

   If you only want to select work centers in a hierarchy for the report, enter data in the Selection by hierarchy screen section. Refer to Reporting from Hierarchy Work Centers only [Page 116]

3. | Choose... | if the report... |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Program → Execute</td>
<td>should be created and displayed</td>
</tr>
<tr>
<td>Program → Execute and print</td>
<td>should be created and printed</td>
</tr>
<tr>
<td>Program → Exec in background.</td>
<td>should be created in the background</td>
</tr>
</tbody>
</table>
Reporting from Hierarchy Work Centers only

Prerequisites
You can select only hierarchy work centers in specified hierarchy levels for standard reports [Page 115] and change documents [Page 117].

Procedure
1. If required, enter the work center (plant and key) from which the hierarchy explosion should start.
   If you do not enter a work center, the whole hierarchy is exploded.
2. Set the *Hierarchy explosion* indicator in the *Selection by hierarchy* screen section.
   
   The *Hierarchy explosion* indicator is automatically set in the *Work ctr hierarchy* standard report.
3. Enter the name of the hierarchy and its plant.
4. Enter the number of steps over which the hierarchy should be exploded.
   If you do not enter a value here, the hierarchy is exploded down to the lowest level.
Displaying Change Documents

Prerequisites

Changes to data elements in work centers are logged in change documents. Changes to data elements are only logged in change documents if the following indicators have both been set:

- The *Change doc* indicator in Customizing for *Work centers* under *Define work center category*.
- The *Change document* indicator for the data element in the Data Dictionary.

For more information, see *BC ABAP Workbench* under *Extended applications function library → Change documents*.

You can use selection criteria to compile a list of change documents, for example, you can display the change documents for a certain person responsible or those produced on a particular date. All the changes made in one session are contained in one document number.

Procedure

1. From the *Work center* area menu choose *Reporting → Change documents*.
2. Enter your selection criteria, for example, plant or task list type.

   ![Tip]
   If you only want to select change documents from work centers in a hierarchy for the list, enter data in the screen section *Selection by hierarchy*. Refer to *Reporting from Hierarchy Work Centers only [Page 116]*.

3. Choose...

<table>
<thead>
<tr>
<th>Choose...</th>
<th>If the report...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program → Execute</td>
<td>should be created and displayed</td>
</tr>
<tr>
<td>Program → Execute and print</td>
<td>should be created and printed</td>
</tr>
<tr>
<td>Program → Exec in background.</td>
<td>should be created in the background</td>
</tr>
</tbody>
</table>
Displaying Where-used Lists for Work Centers

Prerequisites
Where-used lists display the task lists in which a work center is used.

Selection Criteria
You can specify which task list types should be evaluated in a where-used list by using selection criteria such as task list usage or material number.

If you enter **key date**, the system only searches in operations that are valid on this date.

Overview Variants
Which task list objects (for example, header, sequence or operation) are displayed depends on the selected overview variant. Overview variants are defined in Customizing for Routings by using General data → Define overview variants for object overviews.

Procedure
1. From the Work center area menu choose Reporting → Where-used → Work center
2. Enter the work center and plant whose use you want to display.
3. If required, enter a key date and other selection criteria.
5. Enter an overview variant [Page 119] and choose Enter
   The system displays a list of task lists in which the work center is used.

How to call up a view of a task list object from the where-used list:

<table>
<thead>
<tr>
<th>View</th>
<th>Select the object and choose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Detail (such as header)</td>
<td><strong>Goto</strong> → <strong>Details</strong></td>
</tr>
<tr>
<td>Overview (such as header overview)</td>
<td><strong>Goto</strong> → <strong>Choose</strong></td>
</tr>
</tbody>
</table>
Selecting Overview Variants

Prerequisites
You can select different overview variants for work center where-used lists [Page 118]. You define these variants in Customizing for routings by using General data → Define overview variants for object overviews.

Procedure
1. From the Work center Where used: selection screen choose settings → Object overview.
   The dialog box Enter overview variant appears.
2. Enter the overview variant.
3. Choose Enter.
Displaying Where-used Lists for Capacities

**Prerequisites**

A where-used list for capacities lets you know in which work centers a selected capacity is used.

- Pooled capacity
- Scheduling basis
- To copy from

You can limit the extent of the where-used list by entering data about the plant, the capacity category or planner group.

**Procedure**

1. From the Work center area menu choose Reporting → Where-used → Work center
   - The Capacity Overview screen appears.
2. Enter the name of the capacity.
3. If necessary maintain further selection criteria
4. Select the required capacity usage
5. Choose Program → Execute.
   - The system displays a list of work centers in which the capacity is used.
   - If you want to display one of the work centers, select the work center and then choose Edit → Choose.
Replacing Work Centers in Task Lists

You can replace work centers

- Manually in the task list operations
- Automatically in all task lists, in which the work center is used (mass replacement).

Replacing work centers manually in operations

When you replace a work center in an operation with another, the following data is transferred to the new work center:

- Basic Data
- Default values and activity types, which have their reference indicator set.
- Performance Efficiency Rate Key

The units of measure for the default values are not transferred. The rules of maintenance [Page 25] for the new work center are valid for the default values.

Mass replacement

This can be conducted either online or in batch mode. You can work from the area menus for either Work centers or Routings.

💡

Replacing work centers in routings is described in detail in the R/3 Library PP Routings - Changing and deleting routings as well as Mass changes and where-used lists.
Initial Phase of Mass Replacement of Work Centers

Prerequisites

You can carry out mass replacement of work centers

- In the Work centers area menu
- In the Routings area menu.

The rest of this topic only describes the start of mass replacement. For more details refer to the R/3 Library Routings by choosing Mass changes and where-used lists.

Procedure

Starting from the Work centers area menu

In the Work centers area menu choose Work center → Replace.

The Replace Work Center: Selection screen appears.

Starting from the Routings area menu

In the Routings area menu choose Extras → Mass Replace → Work centers.

The Replace Work Center: Selection screen appears.
Configuration of Work Centers

When you create a work center you have to enter the work center category with which you determine

- Which data can be entered in the work center
- Whether the data fields [Page 124] are mandatory or optional
- In which task lists the work center can be used in
- Whether change documents are created for the work center

Work center categories are defined in Customizing work centers under Define work center category.

You can also create a default work center [Page 125] for each work center category and a default capacity [Page 126] for each capacity category. You enter data in the default work center and in the default capacity that is copied when you create a work center or a capacity.
Field Selection in Work Centers

Field Selection in Work Centers

In Customizing Work Centers under Define field selection, you can define the properties of selected data fields in work center screens.

A data field can be defined as:

- an entry field
- a required entry field
- a hidden field
- a highlighted field

The properties of the data fields in each screen group can be defined

- in the Modified field view
- in the Influencing view

Screen groups are for instance:

- Basic Data
- Default values
- Scheduling
- Capacity overview

The work center category for field selection is an influencing field in the work center in the standard system. This is the work center category that is used as a reference when you define field selection in Customizing.

You want to specify in Customizing that only the standard value key SAP1 is used for work center category 0001:

1. Enter the standard value key SAP1 for work center category 0001 in the default work center [Page 125].
2. Set the field Standard value key for work center category 0001 to display.
Default Work Center

You can define a default work center for each work center category in a plant in Customizing work centers under Define work center category.

When you create a work center the system automatically transfers data from the default work center to the new work center.

Descriptions (short and long text) are not transferred from the default work center.

You can reduce the effort needed in working with work centers by editing default work centers correctly.

Default work centers are used exclusively for copying default values. They do not have an object ID.
Default Capacity

You can define a default capacity for each capacity category in a plant in Customizing Work centers under Define default capacity.

Default values for the data in the header screen [Page 59] of capacity maintenance are entered in default capacities.

When you create a capacity, the system automatically transfers data from the default capacity to the capacity.

Descriptions (short and long text) are not transferred from the default capacity.

Default capacities are used exclusively for copying default values. They do not have an object ID.
Formulas

You use formulas in the work center to calculate the following data in costing, scheduling and capacity planning:

- Costs
- Execution times for production orders
- Internal processing times for networks and maintenance orders
- Capacity requirements.

In the R/3 System you can

- use predefined SAP formulas
- define your own formulas.

You can create formulas in Customizing Work centers under Define formulas for work centers.

Relationships between work centers, routings and formulas

The following graphic illustrates the relationships between work centers, routings and formulas for costing, scheduling and capacity requirements calculation. Formulas are entered in the work center; they take their values from the work center (formula constants) and the routing (standard values, general operation data and user-defined fields).
Relationships between work centers, routings and formulas

**Costs**

In production orders each of up to six standard values in a work center can be assigned an activity type and a formula with which the costs of the operations conducted in the work center are calculated.

For networks and service orders an activity type and formula can be defined.
Execution Time
You use formulas to calculate execution time and consequently the duration of operations, which you need to schedule production orders.

You can calculate the execution time for each operation segment separately (setting up, processing and tearing down) by assigning a formula to each of these segments. The execution time for the whole operation is the sum of the execution times of the individual segments. You can however just assign a formula to one segment (for instance processing), in which you take into account the durations of the other segments.

If you do not assign a formula to an operation segment, the execution time of this segment will be set to zero.

The program checks that the formula has the dimension “time”.

Internal Processing Time
Formulas are used to determine internal processing time for scheduling networks and maintenance orders, for example. If you do not enter a formula, the system will use the time given in the network or maintenance order.

The program checks that the formula has the dimension “time”.

Capacity Requirements
You can assign a formula to each operation segment (setting up, processing and tearing down) to calculate the capacity requirements. The capacity requirements for the whole operation are then calculated from the individual segments. If you do not assign a formula to an operation segment, the execution time of this segment will be set to zero.

You can also use a formula to calculate capacity requirements for internal processing in a network or a service order.

If you do not enter a formula, no capacity requirements will be determined.

For more information about this section, see:
Formula Parameters [Page 130]
Rules for Maintaining Formulas [Page 132]
Formula Parameter

A formula is identified by its formula key. It is composed of formula parameters that are identified by parameter IDs.

You create formula parameters and formulas in Customizing for work centers:

- Formula parameter in Define formula parameters for work centers
- Formulas in Define formulas for work centers

You assign each formula parameter to a data field in the work center or routing. When the formula is evaluated, each formula parameter has the value that you have entered in the corresponding data field.

The Origin of Formula Parameter Values

You must enter the origin of every formula parameter in Customizing. The origin controls the assignment of formula parameters to data fields. According to its origin a formula parameter is either automatically assigned to a data field or you have to enter a field name as well as the origin.

You can refer to formula parameters in work centers or routings either by the parameter ID or by the key word, which you have to assign to every formula parameter in Customizing. This key word appears with the assigned field in the work center or routings screen.

Formula parameter values can have the following origins:

- **Standard value**
  With the help of the standard value key you can assign up to six formula parameters for standard values to a work center and consequently to an operation in a routing.

- **Formula constants in the work center**
  You can assign a constant value and a unit to up to six work center constants.

- **General formula constants**
  You assign general formula constants a fixed value and an unit in Customizing for Formula parameters

- **General operation value**
  The formula parameter is linked to a data field in the general operation data. Typical fields are:
  - Lot size
  - Base quantity
  - Number of splits (partial lots)
  - Number of employees
  If formula parameters have this origin, you must enter the corresponding field names in Customizing.

- **User-defined field in the operation**
  The value of a user-defined field in the operation is assigned to the formula parameter.
In this case the user-field key also controls the assignment of the formula parameter to the data field by making two data fields available for formula parameters. You define user-field keys in Customizing Routings under Create user-defined fields. The key words, with which the data fields are labeled in the operation, are not defined in the formula parameter directly, but in the user-field key.

- **Field in production resource/tool (PRT) assignment**
  
  You assign a data field in the production resource/tool assignment to the formula parameter, for example:
  
  - the quantity of the PRT
  - the usage value of the PRT

- **Production resource/tool constants**
  
  You assign constant values to the formula parameters in the PRT master record. These formula parameters can only be used in formulas for PRT management.
Rules for Maintaining Formulas

Formulas and formula parameters are maintained in Customizing - Work center:

- Formula parameter in Define formula parameters for work centers
- Formulas in Define formulas for work centers

You must define formula parameters that you want to use before you create formulas, if you do not want to use formula parameters that have been defined by SAP.

Usage Indicator

You use an indicator to determine where the formula should be used, for example in scheduling and costing.

General Rules

- A formula can be up to three lines long.
- There must be at least one space between operand and operator. Exception: brackets in a function, for example, SIN(A).
- Formulas use the same syntax as the ABAP statement COMPUTE. For further information see ABAP User's guide in the Basis documentation under Numerical operations.
- Units are converted automatically.

Permissible Operations

<table>
<thead>
<tr>
<th>Operation Type</th>
<th>Permissible Operations</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arithmetic functions</td>
<td>+, -, *, /</td>
</tr>
<tr>
<td>Trigonometric functions</td>
<td>SIN, COS</td>
</tr>
<tr>
<td>Integral division</td>
<td>DIV, MOD</td>
</tr>
<tr>
<td>Square root</td>
<td>SQRT</td>
</tr>
<tr>
<td>Exponential function</td>
<td>EXP</td>
</tr>
<tr>
<td>Natural logarithm</td>
<td>LOG</td>
</tr>
</tbody>
</table>

Splits in Formulas

If you want to take splits into account in a formula, you must explicitly enter the split in a formula parameter.

💡

In scheduling to calculate the execution time, the lot size is divided by the number of partial lots. In capacity planning to calculate the capacity requirements, the set-up time is multiplied by the number of partial lots.
Example: Standard Formula

In this example the execution time of an operation is defined as the sum of the set-up time and the processing time. This is expressed in the following formula

\[ F = \text{SET} + \text{RUN} \times \frac{\text{LOT}}{B} \]

The meaning of the formula parameters and the origins of their values are given in the table below.

<table>
<thead>
<tr>
<th>Formula Parameter</th>
<th>Meaning</th>
<th>Origin</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Base quantity</td>
<td>General operation value</td>
</tr>
<tr>
<td>LOT</td>
<td>Lot size</td>
<td>General operation value</td>
</tr>
<tr>
<td>RUN</td>
<td>Processing time for base quantity</td>
<td>Standard value</td>
</tr>
<tr>
<td>SET</td>
<td>Set-up time</td>
<td>Standard value</td>
</tr>
</tbody>
</table>

You can assign just one operation segment, for example the processing segment, a formula to calculate the execution time of the whole operation. You do not assign formula to the other segments.

Calculations with Several Formulas

Since the program adds together the times of the two segments, you can use two formulas, \( F_1 \) and \( F_2 \) for the segments.

- Operation segment set-up: \( F_1 = \text{SET} \)
- Operation segment processing: \( F_2 = \text{RUN} \times \frac{\text{LOT}}{B} \)

This is useful, if you are interested in the times of the individual segments.

💡

The formulas and parameters used here, \( F \), \( F_1 \), \( F_2 \), \( B \), \( \text{LOT} \), \( \text{SET} \) and \( \text{RUN} \), are only valid in this example. In the SAP standard system formulas and parameters are defined for various applications with different formula key words and parameter IDs.
Example: Formula for Periodic Setup

The execution time of an operation is here defined as the sum of the times for setup, processing and repeated setup during processing. This can be expressed with the following formula:

\[ F = SET + \text{RUN} \times \frac{\text{LOT}}{B} + \text{SET2} \times \left( \frac{(\text{LOT} - 1)}{\text{SI}} \right) \]

The meaning of the formula parameters and the origins of their values are given in the table below.

<table>
<thead>
<tr>
<th>Formula Parameter</th>
<th>Meaning</th>
<th>Origin</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Base quantity</td>
<td>General operation value</td>
</tr>
<tr>
<td>LOT</td>
<td>Lot size</td>
<td>General operation value</td>
</tr>
<tr>
<td>SI</td>
<td>Setup interval</td>
<td>Standard value or Formula constant</td>
</tr>
<tr>
<td>RUN</td>
<td>Processing time for base quantity</td>
<td>Standard value</td>
</tr>
<tr>
<td>SET</td>
<td>Setup time before processing</td>
<td>Standard value</td>
</tr>
<tr>
<td>SET2</td>
<td>Setup time during processing</td>
<td>Standard value</td>
</tr>
</tbody>
</table>

The setup interval is here the number of items that are produced before setup is repeated.

You can assign just one operation segment, for example the processing segment, a formula to calculate the execution time of the whole operation. You do not assign formula to the other segments.

Calculations with Several Formulas

Since the program adds together the times of two segments, you can use two formulas, F1 and F3 for the segments.

<table>
<thead>
<tr>
<th>Operation segment set-up:</th>
<th>F1 = SET</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operation segment processing:</td>
<td>F3 = \text{RUN} \times \frac{\text{LOT}}{B} + \text{SET2} \times \left( \frac{(\text{LOT} - 1)}{\text{SI}} \right)</td>
</tr>
</tbody>
</table>

This is useful, if you are interested in the times of the individual segments.

The formulas and parameters used here, F, F1, F3, B, LOT, etc. are only valid in this example. In the SAP standard system formulas and parameters are defined for various applications with different formula key words and parameter IDs.
Example: Formula for Annealing Furnace

Exactly 200 workpieces fit into an annealing furnace. However 201 workpieces have to be annealed. In this case two runs are necessary, the annealing time is doubled.

The execution time is the sum of the setup time and the annealing time multiplied by the number of runs. This is expressed in the following formula

\[ F = \text{SET} + \left( \frac{\text{VOL}_B}{B} \times (\text{LOT} - 1) \div \text{VOL}_F + 1 \right) \times \text{RUN} \]

The meaning of the formula parameters and the origins of their values are given in the table below.

<table>
<thead>
<tr>
<th>Formula Parameter</th>
<th>Meaning</th>
<th>Origin</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Base quantity</td>
<td>General operation value</td>
</tr>
<tr>
<td>LOT</td>
<td>Lot size</td>
<td>General operation value</td>
</tr>
<tr>
<td>RUN</td>
<td>Annealing time</td>
<td>Standard value</td>
</tr>
<tr>
<td>SET</td>
<td>Setup time before processing</td>
<td>Standard value</td>
</tr>
<tr>
<td>VOL_B</td>
<td>Volume of the base quantity</td>
<td>Standard value</td>
</tr>
<tr>
<td>VOL_F</td>
<td>Volume of the annealing furnace</td>
<td>Standard value or</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Formula constant</td>
</tr>
</tbody>
</table>

You can assign just one operation segment, for example the processing segment, a formula to calculate the execution time of the whole operation. You do not assign formula to the other segments.

Calculations with Several Formulas

Since the program adds together the times of two segments, you can use two formulas, \( F_1 \) and \( F_4 \) for the segments.

\[
\begin{align*}
\text{Operation segment: Set-up} & \quad F_1 = \text{TR} \\
\text{Operation segment: Process} & \quad F_4 = \left( \frac{\text{VOL}_B}{B} \times (\text{LOS} - 1) \div \text{VOL}_\text{GO} + 1 \right) \times \text{TE}
\end{align*}
\]

This is useful, if you are interested in the times of the individual segments.

The formulas and parameters used here, \( F \), \( F_1 \), \( F_4 \), \( B \), \( \text{LOT} \), \( \text{SET} \), etc., are only valid in this example. In the SAP standard system formulas and parameters are defined for various applications with different formula key words and parameter IDs.
Using Formulas in Work Centers

You can use formulas in work centers in the Capacities, Scheduling and Assignment (Costs) views.

From these views you can:

- Display formulas
- Test formulas
- Assign a value to a formula constant
Displaying formulas

In the Capacities, Scheduling or Assignment view place the cursor on the formula key (Page 130) and choose Extras → Formula → Test.
Testing formulas

1. In the Capacities, Scheduling or Assignment view place the cursor on the formula key and choose Extras → Formula → Test.
   The system displays the dialog box Test Formula.
2. Enter test data for the formula parameters [Page 130]
   If there are user-defined fields in the formula, enter the field key and the value with units.
3. Choose Calculate.
Assigning Values to Formula Constants

1. In the Capacities, Scheduling or Assignment view choose Extras → Formula → Formula constants.

   The system displays the dialog box Formula Constants.

2. Enter the parameter ID of the formula constant [Page 130] and its value with unit.

   ![Tip]

   You can enter up to six formula constants in a work center.